POJ-2421 Constructing Roads


传送门:POJ - 2421

题目描述

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

输入描述

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

输出描述

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

思路分析

也是村庄连通问题,这题不一样的地方在于:已经有Q条道路已经修好。我们可以通过并查集的连通操作将已经连通的两个村庄标记。

样例输入

3
0 990 692
990 0 179
692 179 0
1
1 2

样例输出

179

AC代码

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <cmath>
#include <vector>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iomanip>
#include <iostream>
#include <algorithm>
#include <functional>

using namespace std;

#define ll long long
#define ull unsigned long long
#define IOS ios_base::sync_with_stdio(0); cin.tie(0);cout.tie(0);

const int maxn=1e6+10;
const ll mod=1e9+7;
const int INF = 0x3f3f3f3f;

int f[10000],n;

struct node{
    int x,y,m;
}s[10000];

int cmp(node a,node b){
    return a.m<b.m;
}


int find(int x){
    if(f[x]==x)
        return x;
    else
        return f[x]=find(f[x]);
}

int unite(int a,int b){
    int t1,t2;
    t1=find(a);
    t2=find(b);
    if(t1!=t2){
        f[t2]=t1;
        return 1;
    }
    return 0;

}



int main() {
    IOS;
    while(cin>>n&&n){
    int k=0;
    for(int i=1;i<=n;i++)
        f[i]=i;
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            int le;
            cin>>le;
            if(j>i){
                s[++k].x=i;
                s[k].y=j;
                s[k].m=le;
            }
        }
    }
    int cnt=0,ans=0;
    int t;
    cin>>t;
    for(int i=0;i<t;i++){
        int a,b;
        cin>>a>>b;
        if(unite(a,b))
            cnt++;
    }
    sort(s+1,s+1+k,cmp);
    for(int i=1;i<=k;i++){
        if(unite(s[i].x,s[i].y)){
            cnt++;
            ans+=s[i].m;
        }
        if(cnt==n-1)
            break;
    }
    cout<<ans<<endl;
    }
    return 0;
}

文章作者: 小凡
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 小凡 !
评论
  目录
隐藏
{% if theme.sakura.enable %}{% endif %}