传送门:HDU - 1241
题目描述
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
输入描述
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each . Each character corresponds to one plot, and is either *, representing the absence of oil, or @’, representing an oil pocket.
输出描述
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
题意分析
一道dfs板子题,油的四面八方为同一个,所以找到一个它四面八方全部标记并往下继续搜索
样例输入
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
样例输出
0
1
2
2
AC代码
#include<bits/stdc++.h>
#pragma GCC optimize(2)
using namespace std;
typedef long long ll;
typedef pair<int, int> pii;
typedef pair<ll, ll> pll;
typedef map<int, int> mii;
typedef map<ll, ll> mll;
#define ull unsigned long long
#define IOS ios_base::sync_with_stdio(0); cin.tie(0);cout.tie(0);
const int maxn=1e6+10;
const ll mod=1e9+7;
const int INF = 0x3f3f3f3f;
int n,m,i,j;
char a[200][200];
void dfs(int x,int y) {
if(x>=n||y>=m||x<0||y<0||a[x][y]=='*')return ;
a[x][y]='*';
dfs(x-1,y-1);
dfs(x,y-1);
dfs(x+1,y-1);
dfs(x-1,y);
dfs(x+1,y);
dfs(x-1,y+1);
dfs(x,y+1);
dfs(x+1,y+1);
}
int main() {
IOS;
while(cin>>n>>m) {
if(n==0)return 0;
memset(a,0,sizeof(a));
for(i=0; i<n; i++) {
for(j=0; j<m; j++) {
cin>>a[i][j];
}
}
int sum=0;
for(i=0; i<n; i++) {
for(j=0; j<m; j++) {
if(a[i][j]=='@') {
sum++;
dfs(i,j);
}
}
}
cout<<sum<<endl;
}
}